XTRA Kills My Emails

It turns out that my ISP has changed its email policies . When I send emails from a separate email address than the one registered with my ISP, my emails are not being sent. I have no idea when telecom introduced this system, they did not bother me with any details about this.

I was talking to a friend yesterday and I said, “did you get my email?” Imagine my surprise when he told me that he has not had an email from me since the 3rd of June. What has been happening? It took a long time to sort out that this was not my fault. I found that if I use my .mac or gmail account to send my emails they were sent successfully. So, it finally occurred to me that the problem was with my ISP, they must have changed something.

It turns out that they have brought in a new system to control spam. Rather than tell their customers, XTRA will let their customers find out for themselves. And rather than warn their customers that the sent email will not be forwarded on, XTRA will just wait for you to find out on your own somehow.

I have just spent most of the morning on the phone to XTRA. The tech support people are helpful, but that is not the issue. The issue is that XTRA have decided on a change to the security system, and have not warned the users that they will have to add passwords to their ISP accounts, and they will have to change the mail settings and ports, on all accounts, for me and all the members of my family, on all the computers.

Shame on you XTRA! you should have told us in advance…

So, if you haven’t had my emails for a while, I’m sorry, XTRA has been killing them…

Leave a Reply